From YiPs Wiki (i powered)

XMLService: Ruby Gem Install

Goto Main Page
Goto Documents
Goto Ruby Page

IBM i

CLI drivers on IBM i are included (PASE libdb400.a), you do NOT need DB2 Connect products on IBM i.

IBM i install

Both gems in development, use included zzall.sh to install.

1) ibm_db gem use zzall.sh script 
ssh me@myibmi
export PATH=/path/myRuby/bin:$PATH
export LIBPATH=/path/myRuby/lib
unzip ibm_db-2.5.14.gem.devel_GA02.zip   (http://youngiprofessionals.com/wiki/index.php/XMLSERVICE/XMLSERVICERuby)
cd ibm_db-2.5.14.gem.devel_GA02
./zzall.sh

2) xmlservice gem use zzall.sh script
ssh me@myibmi
export PATH=/path/myRuby/bin:$PATH
export LIBPATH=/path/myRuby/lib
unzip xmlservice-1.2.0.devel_GA3.zip    (http://youngiprofessionals.com/wiki/index.php/XMLSERVICE/XMLSERVICERuby)
cd xmlservice-1.2.0.devel_GA3
./zzall.sh

Note: xmlservice gem does NOT require ibm_db, but you will need a REST yml file 

Linux/Unix/Windows DB2 Connect 10.5

To connect to IBM i, you must use DB2 Connect product (10.5), and you must purchase a license.

Linux Install

Linux same, except you will need to purchase a license for DB2 Connect 10.5 to IBM i

Compile:
export PATH=/opt/ibm/db2/V10.5/bin:$PATH    (wherever db2 installed)
export IBM_DB_HOME=/home/db2inst1/sqllib    (wherever db2 installed)
./zzall.sh

Operation:
$ sudo cp /opt/IBM/db2/V10.5/cfg/db2cli.ini.sample /home/db2inst1/sqllib/cfg/db2cli.ini
$ sudo chmod +w /home/db2inst1/sqllib/cfg/db2cli.ini
$ sudo e /home/db2inst1/sqllib/cfg/db2cli.ini &
; Comment lines start with a semi-colon.
; Database name can be found WRKRDBDIRE
[LP0364D]
Database=LP0364D
Protocol=tcpip
Hostname=lp0364d.rch.stglabs.ibm.com
Servicename=446
SchemaList=”*USRLIBL”

DB2 Connect 10.5 license and setup

Mmmm … few issues growing knowledge center

My notes (older install)

Archive: DB2 Connect 10.1 information (10.5 recommended)

Retrieved from http://youngiprofessionals.com/wiki/index.php/XMLService/RubyGemInstall
Page last modified on October 09, 2014, at 10:42 AM EST